Home > Vmware Converter > Ubuntu P2v

Ubuntu P2v

Contents

Disconnect DVD from Virtual machine and reboot. 12. This time it will cover more of the Debian based distribution. Reply Uli B. if you want to contact me directly, i can be reached via great [dot] dilla [at] gmail [dot] com.

Identify the disk containing root file system (e.g. /dev/sda1) 7. It should be: grub-install (GNU GRUB 1.98+20100804-14+squeeze1) To fix this I added the following to /usr/sbin/grub-install: Code: if [ $# -eq 1 -a "$1" = "-v" ] ; then echo "grub-install VMware Virtualization Advanced .VMX File Configuration Video by: Brian Teach the user how to edit .vmx files to add advanced configuration options Open vSphere Web Client: Edit Settings for a VM: You might also be interested in: Feedback We at pimp-my-rig strive to keep on improving, help us reach that goal by leaving comments or constructive criticisms.

Ubuntu P2v

Grub install devices Next up: unmount your Server ISO and reboot the system, it should boot just fine now. Will you help me share it on social media? switched the network adapter from E1000 to VMXNET 3 and still can't resolve the mirrors. As it turns out, you require the Linux Security Remix ISO file.

  1. But still so far away :-( edge, Jul 13, 2012 #6 falko Super Moderator ISPConfig Developer What's in /etc/fstab?
  2. However, if this is not present on your system, the command "blkid" will show the same information. [[email protected] ~] sudo blkid /dev/sda1: UUID="a4fc19b3-6df9-4fcb-a565-12a9bd59fff1" TYPE="ext4" /dev/sda5: UUID="1061e56a-f69d-4d44-b3d1-566c960719b1" TYPE="swap" The above entries need
  3. No error reported # After this I reboot, and it does show the installed kernals (looking good so far) Then..
  4. Run update-grup in the recovery console Run "exit" to exit the recovery console Select "Reboot the system" At this point one of the systems I was working with booted fine, most
  5. When you run the Converter as is, it will give an error when 99% is done of the converting.
  6. The fix for version parsing didn't get into 5.5.
  7. The Debian OS will boot successfully. 13.
  8. No, create an account now.
  9. jperlorx Feb 12, 2015 5:04 AM (in response to Plamen) Hola,I installed the GRUB2 cversion for ubuntu server and still gives me the same error, attached logFAILED: An error occurred during
  10. Showing Authentication Failure.

I'm going to do a new "clean" install, and move all the accounts from the Xenserver VM to the new VMware vSphere VM! falko, Jul 14, 2012 #7 edge Active Member Moderator falko said: ↑ What's in /etc/fstab? This VM the are (see also 2nd post): /dev/sda1 (set to boot) /dev/sdb1 On the Xenserver they are: /dev/xvda1 (set to boot) /dev/xvdb1 Code: host:~# fdisk -l Disk /dev/xvdb: 1073 MB, Update /boot/grub/grub.cfg with correct UUID’s for boot disk. 11.

Connect with top rated Experts 14 Experts available now in Live! When asked "Select a Disk" I used the option "Use an existing virtual disk.....", and selected the ".vmdk". Plamen Feb 13, 2015 2:14 AM (in response to jperlorx) Ah, sh*t! https://mantraaz.wordpress.com/2012/10/06/vmware-p2v-conversion-grubinstaller-error-during-conversion-of-debian-linux-host/ Comment any entries for swap file system.

Try Free For 30 Days Join & Write a Comment Already a member? Last edited by essefbx; August 24th, 2012 at 10:02 PM. Booting the kernell _ After this the VM just sits there.. (looks like hanging) I'm about to give up on this... edge Active Member Moderator I've got a XenServer VM what I would like to convert to VMware.

Vmware Converter For Linux

This may still fail if the new hardware has compatibility issues with drivers on the old software. I can also ping the server from my local, but can't ping anything from the server. Ubuntu P2v If you're interested in keeping up with me, have a look at my podcast and weekly newsletter below. Vmware Vcenter Converter The other machine got a chill inducing error accompanied by a busybox prompt: Alert! /dev/disk/by-uuid/ does not exist If you still can't boot: Boot the VM to an Ubuntu 12.04

Any help is much appreciated. Re: Error: Unable to reconfigure the destination virtual machine. for "initrd.img-3.2.0-39-generic" you need "3.2.0.-39-generic") Run something like "update-initramfs -u -k 3.2.0-39-generic" replacing the version with the one found above Run "exit" to exit the recovery console Select "Reboot the system" jperlorx Feb 13, 2015 1:34 AM (in response to Plamen) Version of grub-install [email protected]:/etc/default$ grub-install --versiongrub-install (GRUB) 2.02~beta2-9ubuntu1 Like Show 0 Likes (0) Actions 8. Vmware Converter Download

Reply Manjeet Nov 30, 2012 @ 16:23:12 Look for UUID of boot disks and other devices. If it's not been tested and confirmed working on a flavour of Linux it is even more difficult to troubleshoot, at 99% it's trying to install Customization/Reconfig/VMware Tools usually. Click to expand... Anywhere else TAB lists the possible completions of a device/filename. ] grub> root (hd0,0) grub> setup (hd0) Checking if "/boot/grub/stage1" exists...

What is the error from the GRUB2 attempt? The UUIDs can be obtained by running "blkid" from the recovery console. Last edited: Jul 12, 2012 edge, Jul 12, 2012 #4 falko Super Moderator ISPConfig Developer Should be either Code: grub-install /dev/sda or Code: grub-install /dev/xvda If the device doesn't exist, the

edge, Jul 18, 2012 #15 (You must log in or sign up to reply here.) Show Ignored Content Share This Page Tweet Log in with Facebook Log in with Twitter Log

Do you have multi-boot configured? If you like my ideas, will you buy me coffee? no Checking if "/grub/stage1" exists... This can "in theory" be done with "VMware vCenter Converter Standalone Client".

Reply Leave a Reply Cancel reply Enter your comment here... Reply ↓ Leave a Reply Cancel reply Your email address will not be published. falko, Jul 13, 2012 #5 edge Active Member Moderator Hi falko.. User contributions on this site are licensed under the Creative Commons Attribution Share Alike 4.0 International License.

It will be in the next release, sorry.It is difficult to manually fix the helper. Re: Error: Unable to reconfigure the destination virtual machine. If you're unsure, check both partitions. From the installation CD we can choice "Install grub on /deb/sda"   LAST STEP reboot   [OT] Let me write some useful commands here HOW TO CHANGE IP, GATEWAY AND DNS

For more updates, follow me on Twitter as @mattiasgeniar. Next, run the following commands (you may have to alter the config a bit to your partition layout). ~# fdisk -l /dev/sda1: boot /dev/sda2: swap /dev/sdb1: root With fdisk -l I FAILED: An error occurred during the conversion: 'GrubInstaller::InstallGrub: /usr/lib/vmware-converter/installGrub.sh failed with return code: 127, and message: Installing GRUB1 on (hd0)... /vmware-updateGrub.sh: 52: /vmware-updateGrub.sh: grub: not found Error installing GRUB Command: grub Comments Alex Thursday, April 19, 2012 at 10:56 That's nice tip ) Good job!

In theory... Re: Error: Unable to reconfigure the destination virtual machine. fstab looks like this: Code: proc /proc proc default 0 0 /dev/xvda1 / ext3 errors=remount-ro,usrquota,grpquota 0 1 /dev/xvdb1 none swap sw 0 0 I've also tested this, but with no luck Plamen Feb 12, 2015 6:59 AM (in response to jperlorx) HiConverter determines the grub version by calling grub-install.

This was a tough one to resolve at first. The system is now ready for use. for help): w   FSTAB fstab file still contains the phisical machine information /dev/sda2 / ext4 errors=remount-ro,relatime,usrjquota=quota.user,grpjquota=quota.group,jqfmt=vfsv0 0 1 /dev/sda3 swap swap defaults 0 0  We have to change sda2 with sda1 Reboot and verify system configuration and network configuration. 16.