Home > Wine Error > Wine Error Loading Shader Libraries

Wine Error Loading Shader Libraries

So any ideas what i should do to make it runnable? I have alot of faith invested in Cedega to get this working. In Command Prompt -> DXDIAG it says I have DirectX 11. I mean, if I have a library under .wine/drive_c/windows/system32 is that the native or builtin place? this contact form

I, so far, haven't had to install MSXML3...I haven't bothered viewing that link yet, since I'm up and running without Native MSXMK3...Apparently... Civ4Questions, Dec 5, 2009 #3 ori Repair Guy Staff Member Super Moderator Joined: Dec 17, 2005 Messages: 15,760 Location: Baden-W├╝rttemberg, Germany microsoft in their wisdom removed some code from the dx10 Melhisedek & zorkerz are you using ATI graphic cards? Game doesn't work for me in Cedega (crashes X), and doesn't work in wine .44, or .48 (only worked at all on .47 ).

If anybody knows how to fix this, your help would be greatly appreciated. Taken from appdb (http://appdb.winehq.org/objectManager.php?sClass=version&iId=9501) sojusnikDecember 3rd, 2007, 12:04 PMIs it possible to play Civ IV with all addons and latest patches with WINE via Internet with a pal who has the If yes, install it.

  • Finally I just went to Windows Explorer and deleted everything in the Programs file dealing with Civ4 or Civilization, then deleted everything in the MyGames in My Documents folder.
  • I'd point ATI as the culprit here but that's just a wild guess considering the nature of their (preciously?) bad drivers.
  • I really am at a loss.

Or rephrasing the question, where are the builtin libraries and where are the native libraries? I copied d3dx9_24.dll right up to d3dx9_36.dll to my system32 folder because I read so many different posts, leading up to this one, that suggested random d3dx9_XX files. I also did a few registry tweaks for WOW to work, but Civ4 shows XML error so it shouldn't be that nwadamsDecember 4th, 2007, 06:10 AMdelete the msxml3.dll out of the Check it out and post in Site Feedback if any issue.

Is it comparative or does one work better than the other? Yes. That should resolve your issues with 1.74. http://civ4.error.loading.shader.libraries.winadvice.org/ Stay logged in CivFanatics Forums Home Forums > CIVILIZATION IV > Civ4 - Technical Support > Home Forums Forums Quick Links Search Forums Recent Posts Media Media Quick Links Search Media

OSDir.com wine-bugs Subject: [Bug 25289] Civilization 4: fails with 'errorloading shader libraries' unless native d3dx9_26is used Date Index Thread: Prev Next Thread Index https://bugs.winehq.org/show_bug.cgi?id=25289 --- Comment #8 from genstorm Like in the range of 5 to 10 minutes. eks Display posts from previous: All posts1 day7 days2 weeks1 month3 months6 months1 yearSort by AuthorPost timeSubject AscendingDescending Page 1 of 1[ 2 posts ] Board index»WineHQ»Wine Help It EDIT: i'm using Gentoo and not Ubuntu, i don't really know if this matters or not, but i guess you can still try this process on your ubuntu.

hope everyone can get it to work its a great game nucleon2kJuly 29th, 2007, 06:02 PMJust a quick note here: you can run vanilla Civ IV with the 1.74 update using http://civilization.4.error.loading.shader.libraries.winadvice.org/ Thanks guys Steve KhaaLDecember 5th, 2007, 08:24 PMdid you enable vertex shaders in winecfg (graphics tab)? fixme:cursor:CURSORICON_LoadFromFile No support for .ani cursors. Otherwise, just as good as Windows.

As I was using Wine it jsut auto used my Wine Civ IV install instead of my cedega Civ IV install). weblink It usually just skips it and tries to install the game. An error (-5003 : 0xffffec75) has occurred while running the setup. conjur3rJuly 30th, 2007, 02:24 PMThose who have ordinary Civ 4 running in wine, how does it compare to cedega?

Sorry I am using Gentoo not Ubuntu and i guess wine works differently on the Distros... I don't think its neccesarly to downgrade to 0.9.58, I'm running BTS on RC4 and its working just as fine as it did on previous versions. Thanks! http://discusswire.com/wine-error/wine-error-21.html After that i put another 2 dlls in system32 d3dx9_32.dll and d3dx9_31.dll and play.

After the game installs manually put the two DLL's into the windows system32 directory. bye bye teo_mAugust 23rd, 2007, 02:25 PMi managed to install BTS with wine-0.9.43 and to play! FYI running Ubuntu 7.04 32bit, Civ4 Vanilla 1.74.

fixme:shell:DllCanUnloadNow stub Xlib: extension "XFree86-DRI" missing on display ":1.0".

MelhisedekDecember 3rd, 2007, 03:48 PMI get bug with xml: Caught unhandled exception creating XML parser object: http://img519.imageshack.us/img519/681/xmlsb1.jpg Do you have any solutions? Ok, i will try that. Civ 4 and the Warlords expansion both worked great on Cedega. Where did you get it from please?

Tried the whole msxml3 thingie... nalmethOctober 29th, 2007, 04:25 AMSomewhat related to thread topic, just for reference, To Whom It May Concern: On an Intel 965G integrated graphics card, I have had a damn trouble getting hope this helps. http://discusswire.com/wine-error/wine-error-105.html kstabinsAugust 2nd, 2007, 10:41 PMAhh I understand now.

I set up a Windows XP virtual machine, installed Civ4 + BTS, installed no-cd cracks and then copied the folder over to Linux. Worth noting is I only have Civ IV Vanilla installed thru Cedega and I run both Warlords and BtS from an XP install. Any idea how I can solve this please? Even though i copied over all the dll's.

I┤ve not much hair left to pull out! :guitar: Beamvr6October 3rd, 2007, 08:29 PMI've just got BtS running in 6.0.6 with Cedega 6 something (from about June 2007) and got screenshots It says that I have to first uninstall before reinstalling. what i did: install civ4 normally, then i applied manually the 1.61 patch. MFonvilleSeptember 23rd, 2007, 09:29 PMHmm, have you tried setting your emulation to Windows XP with 'winecfg'?

Yes, my password is: Forgot your password? Cheers Steve teo_mAugust 28th, 2007, 06:04 PMd3dx9.dll doesnt seem to exist (on either my PC or the net) - do a google and you will find the same!